EOSCommunity.org Forums

Retrieving my EOS on Greymass Wallet

In May of 2018 I moved my EOS from myetherwallet to Greymass. I have the public and private keys written down, but that is all. I did not create a password at the time as it wasn’t required. Now I want to access my EOS wallet, which I understand is Anchor. Any ideas how I can do this if I never established a password in Greymass? I have printed out the instructions from teamgreymass entitled "Migrating to Anchor from eos-voter (“Greymass Wallet”). Thank you for any help.

The password is just for the app itself - so you should be just fine. All you need is the private key to get setup in any wallet (Anchor included). I outlined the steps you’ll need to take in a forum post just the other day, which should be enough to get you setup!

  • Grab the latest copy of Anchor from our website: https://greymass.com/en/anchor
  • Install it and get it started up.
  • You’ll be prompted to setup your wallet:
    • Select EOS as the blockchain
    • Setup a password
    • Click “Import Existing Account”
    • Click “Import from Private Key”
    • Enter your private key.
    • Check the checkbox next to the account (active permission) you want to import.
  • You’ll then be setup in our new wallet with your account.

Also to note: you likely won’t need the instructions from that blog post unless you were using a backup from eos-voter to get Anchor setup. The above instructions should be enough to get you going!

Aaron, I downloaded the install as you recommended, but I can’t get it to open up. The application “win-anchor-wallet-1.1.11” is in my download folder, and an anchor icon shows up in my lower taskbar. But when I click on it, nothing happens. I tried shutting down my computer several times as recommended in a previous post. Any ideas? Thank you very much, Andrew

Hrm, that’s strange. The file you downloaded is the installer - so it should be popping up with a standard windows installation process that you’ll run through. Then once it’s installed you would use the start menu or desktop icons to start it up.

What version of Windows are you running? And by chance are you using a ledger?

Aaron; Using Windows 10 Home Version 2004, installed 7/27/2020. I’m not using a Ledger. Thank you. Andrew

That seems like it should be fine.

Have you made it through the installation process and the start up is what’s failing - or is the installation process what’s not working?

I’m wondering if maybe some sort of anti-virus or anti-malware you may have running could be preventing things from working. One other thing to try would be to look within those and see if there’s a temporary way to disable it or some sort of whitelist the application could be added to. I’m using a Windows 10 install with Anchor myself and haven’t seen this issue before.

Aaron; Stupid question; do I need an external hardware wallet like my Trezor for my BTC to make the Anchor wallet work? Thank you, Andrew

Nope, Ledger is optional w/ Anchor. Anchor also doesn’t integrate with BTC at all either, it’s an EOSIO only (EOS, WAX, Telos, etc) wallet.

Still stumped. I have an Anchor icon on my desktop and taskbar, but nothing happens when I click on them.

Thank you very much. Andrew

FYI - For your security, I removed the phone information you posted. We don’t offer that kind of support unfortunately, we don’t have the manpower or the regular hours to do that direct kind of one-on-one help. The support we try to offer is here though through this asynchronous communication.

Have you looked into any sort of security software you’re running like I recommended previously?

I’m asking these questions to rule things out and try to diagnose what’s going on with your machine.

If you also really need access to the account now while we’re figuring out why Anchor isn’t working, you could always grab Scatter, our iOS wallet, or another EOS wallet and import your private keys to perform transactions today.

Aaron; I’m not that good with computers so I will take this one to a computer repair store and see if they can get Anchor to install properly. I tried to sign up for Scatter but couldn’t find anything on a Google search. Do you have a website address for Scatter please? Thank you, Andrew

You can find Scatter here: https://get-scatter.com/

As a word of caution, I’d be careful not to trust anyone with your private keys - so be careful if you’re entrusting a computer store employee to deal with your wallet. That’d be like giving them access to your bank account in some regards :sweat_smile:

Aaron, Note the caution, I was not intending to share my private keys with anyone. I have Google chrome and internet explorer as search engines. I used the former to try unsuccessfully to download win-anchor-wallet 1.1.11. When I tried internet explorer instead, it wouldn’t let me even start, said security risk or something. For security I have both Windows Defender and ESET. How do I whitelist anchor and what is the title to use? Plan B, I successfully set up a wallet on Scatter as you suggested, but can’t figure out how to import my EOS from my greymass wallet. Thank you for any help you can provide. Andrew

For sure - but even beyond sharing private keys I’d even be hesitant to leave my computer in the hands of an untrusted individual I held any sort of keys on that machine. I just wanted to make sure to say something along those lines since alarms went off in my head :wink:

ESET could be the culprit here, I don’t think Windows Defender would get in the way. Anchor is a “signed” application within the Windows ecosystem - but a lot of anti-virus and anti-malware software doesn’t entirely respect and learn to trust that quite as fast. Seeing as how Anchor has a relatively small user base, we have seen some software like this block it from running.

I did some brief googling, and I couldn’t find exactly where you could either “whitelist” or “exclude” an application from being “blocked”. The words in quotes being specifically the queries I was looking for to see if I could find an example. Much of what I found was old software and posts from years ago. Those are the kinds of settings I’d look for in ESET though:

  • If there’s a list of “Blocked Applications”, browse it to see if Anchor is listed and you can remove the block.
  • If there’s a “Whitelist Application” section, you might be able to add Anchor to that list to allow it to run.
  • If there’s an “Exclude from Scanning” section, you again may be able to add Anchor to it.

If for whatever reason you do find one of those, I believe Anchor is going to be installed in the “Program Files” folder on your computer, in a subfolder called “Anchor Wallet”.

Despite the benefit these programs provide, they sure can be a pain to work with if you’re using software that wasn’t built by a multi-million dollar company. They made it hard for us little guys to get things done :frowning_face:

Aaron; Thank you for your ongoing support. Don’t know if I can do it, but what address should I use to whitelist Anchor? You are probably correct the ESET is blocking the download. Do you recommend temporarily disabling the ESET firewall to I can download Anchor? Thank you very much again. Andrew

I don’t think it would be a URL or address that would need to be whitelisted, it’d be the application itself. Without really knowing how ESET works (I’ve never used it, and google results are sparse), I’m not entirely sure.

It’s hard to troubleshoot these types of issues when something is clearly blocking the application from running. I know it works in Windows, we have a lot of Windows users and I am running it on a Windows computer as well - I just am not sure why your computer is preventing it from running :slightly_frowning_face:

Aaron; SUCCESS, sort of. Sent this computer to a local repair shop. The tech disabled Microsoft Defender SmartScreen and installed the Anchor wallet. I show a total balance, a staked balance and only 10 EOS “available”. How do I unstake the larger sum so I can transfer them? As always, thank you

Nice! Glad to hear it. I’ll have to make note of that as a potential solution for others in the future that might run into this issue.

First things first, enable Fuel by clicking the Fuel icon in the top right and clicking “Enable”.

This gives you some free transactions each day - which you’ll need if you’re unstaking it all.

Now to unstake your tokens, what you’ll want to do is go into the “Resources” section. The CPU and NET sections there will have staked balances. You’ll want to click “Unstake” next to each of them and unstake the total quantity you want for that staked amount. Submit it, wait 3-4 days, and it will appear as an available balance.

If after the unstaking time period your tokens do not appear, you might have to manually refund them. To do this, you’ll click the expand button in the resources section:

With it expanded, you’ll see additional details. Once the balance is ready to claim you’ll see a blue “Claim” button in the bottom right near the “Unstaking” section. Click that to manually claim.

If for whatever reason that claim doesn’t work - you can always visit a site like bloks.io and login using Anchor, and then use their refund tool to try it there: https://bloks.io/wallet/resources/refund.

Hi, Aaron:
Thank you very much for your help.

When I tried to do manual claim, it indicates " Error Invalid private key ()", I have checked my computer system clock, it is correct, tried also tried https://bloks.io/wallet/resources/refund again, it continues to fail for the same reason of "Error transaction net usage is too high: 104 > 0 ", should I install another wallet on a different computer to try?

what should I try the next?