EOSCommunity.org Forums

Unable to recover account ower key has been changed, certificate no longer valid

my account is yuan.gm

@aaron may i have your help? the certificated i scanned for account recovery is provided by Anchor Wallet IOS app when i created the account yuan.gm, and so as the 6 certification key.

According to the block explorers, it doesn’t look like your owner key has changed. Did the 6 encryption words get entered correctly while you were recovering? It’s possible that if those words were entered incorrectly or if they were out of order, you might get this error message.

1 Like

i believe that i did not make any mistakes on the 6 encryption words while i was recovering the account.
Further, the reason i tried to recover the account is that i get the below error while i was trying to import my account thru a private key…


@aaron it will be grateful to have you help on that, if needed, i can provide the owner key certificate and the encryption words for investigation in a private way.

Two questions for you:

  1. Is this the same device you created the account with?
  2. Do you still have the account imported on a device?

no, not the same device, as i cannot make transaction thru the device i create yuan.gm, so i tried to import to another device

yes, the ios device i used for account creation still imported the account

Further, i can’t make any transaction thru the device i used for acc creation. when try to make transaction, i will ecounter this error. pls find below user journey i tried to send out wax thru the device i used for creating yuan.gm


![image|230x500]

then i slide to sign, telling me as below


@aaron mai i hv ur help?

Alright awesome. So, on the device you created the account on, I want to walk you through trying to look for the appropriate key, since it seems like multiple keys have been created and potentially the wrong one imported.

On the device you created the account on, try the following:

  1. Go to the home screen of the Anchor iOS app.
  2. Tap the Anchor logo 5 times fast, which should open up the developer tools.
  3. Select the “Keychain Viewer” option.
  4. A list of public keys will appear, you are looking for the one that matches your account.
  5. Check to see if either of these two public keys are in the list:
PUB_K1_797xSJbtFVKi7ijNsMRvDJV8YFbwkZgQkWH1N3AUg9zXoGqznV

or

PUB_K1_5YfhUNVhUmDvcP3fCCgCUg8f31m968NT6tsNKhtbDYwfu47m8w

Based on what I see in the block explorers for your account, those are the public keys associated and in control of your account and what we need to find.

If you find those public keys, export the private keys by clicking on them from the keychain viewer and select “Export private key”. There’s a “Copy key” button in the upper right you can use to copy them, and you can also scan these keys from another device using the QR code to import them.

All of the above should allow you to manually backup those keys, provided they exist in the keychain, and give you access to the account and its assets. It’s not a certificate backup like the app tried to create, but it’s something for now while we work through this problem.


Now for an explanation: it looks like somewhere in our process there’s a bug that generated multiple sets of keys for your account. The account was created using one set of keys, while Anchor imported a different set of keys and prompted you to create a backup using the wrong ones. We’re investigating how this bug could have occurred on our end.

follow the instructions from u, i can c that the key on my ios device is different from block explores, what should i do now? @aaron
@aaron may i have your quick response on this, as i have transfered some usd into yuan.gm, and this acc got problems. it is urgent.



Looks like my initial thoughts of this being a bug might not be the case.

So is this the device you originally created the account on?

yes, it is the device originally created the yuan.gm. how can i move my money out of yuan.gm?
@aaron

@aaron any update?

This is not something we would normally ask - but if the certificate is invalid for the account and you’re certain of that, it might help us further determine what exactly is happening here. For all other situations where the certificate is valid, we’d never recommend sharing it with anyone.

If you’re willing, send it over to team@greymass.com and we will look to see if maybe there’s some information we can gather from this situation.

Sent an email thru my Gmail account 35915647neo@gamil.com attached with owner certificated and encryption words to team@greymass.com. Please help and keep me posted. Many thanks @aaron

Received, we’re investigating on our end to try and see how this is possible.

One question for you, do you have two accounts on the forums? Did you also create this post?

yes, this is post by me as well

Alright thanks - we were just trying to determine if we had two open issues or one, since if you did post both we know that the cause of both issues is the same thing.

One of our developers spent the day yesterday looking into this and is continuing still to investigate. The random questions we are asking are just to help look into the situation. Sorry to keep you, it’s just a pretty odd situation and we’re trying to gather as much information as possible.

thx @aaron , we may communicate timly on this, no matter thru email or forum.

how is the progress? any findings?

Lots of weird findings, which result in weird questions like this: do you remember the date you created this account, and have you ever played Farmers World on WAX?

i created yuan.gm on 20th NOV 2021 china time zone. i planned to use yuan.gm to play farmersworld, so i transfered some wax to yuan.gm to buy tools of farmerworld, but i cannot buy anything now.