EOSCommunity.org Forums

WAX chain - Missing NFT

I am new to the WAX/EOSIO ecosystems, so I apologize if I have made a rookie mistake… luckily, the NFT in limbo was a test before moving ones I care about… anyway, here’s the issue:

I transferred the NFT from the WAX Cloud Wallet to a greymatter provided .gm address I created a few days ago. I can see on bloks.io where everything went smoothly, except when I go to actually view the NFT… it does not appear in the desktop wallet, mobile wallet, or bloks.io.

Hopefully I haven’t lost the item permanently, but if I have, its a lesson I won’t forget.

Any help is very much appreciated! Thank you, sincerely.

Anchor doesn’t display NFTs, but you should be able to see them on one of the external sites in your browser. I’m also not sure if bloks.io displays these.

Have you tried logging into either https://wax.simplemarket.io or https://wax.atomichub.io/ using Anchor to see if they are in your inventory there?

YES! This is exactly the step I needed. So strange that in the block explorer, it has an NFT tab, but it does not display the NFTs in my Anchor Wallet.

Anywho, problem solved! Thank you SO much for the quick response!


While Anchor can perform actions with NFTs, we haven’t had the time to build an NFT inventory into the wallet. Too much work, too little time!

Glad you got it figured out though :+1:

how can i tranfer my nft from my anchor wallet to wax wallet

You’d just transfer it (using whatever interface for NFTs you’re using) to send from one account to the other. I’m not sure which interface you’re using Anchor to log in with, but I’m assuming it has some sort of “Send” feature.