EOSCommunity.org Forums

How do I make sure that Anchor signs with the active key instead of the owner key?

im sorry if im being dumb im new to anchor, i created the account on wax wallet, when i import it to anchor it only shows be the owner key to import, now once i import it in the account permissions i see both the owner key and the active key, and it is saying that it is using the owner key to sign contracts. all i need is to know where in alchor can i tell it to sign with the active key or at what point from creating to importing was that an option i could have chosen

1 Like

Each account/permission combo is imported individually.

You’d go into Manage Wallets, and from there you can import a new account/permission combo. If you want the active permission for an account, you’d go in there and select it.

If the active permission isn’t showing up when you import your key, it’s possible that’s not the key that controls the active permission. With the owner key loaded though, you could always generate a new key pair (Tools → Manage Key) and then use the permissions tool (Tools → Permissions) to change it.

1 Like