EOSCommunity.org Forums

Anchor wallet will only login

I just downloaded the deb file for 1.3.1 and imported my private keys.

I went to wax.blox.io to transfer an NFT and I logged in fine using the launch Anchor link in the dapp. After entering my transfer info,

I am prompted with:
Screenshot from 2021-11-08 00-02-33

which resulted in “Error - Wallet did not respond in time”

There was no other errors or info I saw. There was no indication of the Anchor app having any type of connection with the blok.wax.io dapp.

I read about a modification for a similar error but from using the appimage. I didn’t see how to apply that since I don’t have a desktop file for Anchor. The appimage was tried prior to the deb file also but since it didn’t work, either, I didn’t want to go further down the rabbit hole.

What can I try?

If it’s just hanging on that prompt, it’s possible that Anchor has lost connection with the services it uses to relay transactions between wax.bloks.io and your wallet.

A few things to try include:

  • Log out of wax.bloks.io, and then log back in again. This sometimes fixes the connection for some apps with older software.
  • Try restarting Anchor completely (close it from the file menu or system tray, since it runs in the background).
  • Try a different browser to see if maybe the browser you are using is what’s causing the problem.
  • Check inside Anchor, go in to Tools → Link Service and see if it displays that you’re connected.
  • One final thing to try would be to open the Developer Tools in your browser, and look in the Console tab. With that open, try to perform a transaction and see if there are any errors there.

There are a lot of moving parts to make this all work, and a number of things between the browser, your network, and the app itself that could cause this error. Hopefully one of the above helps track it down.

The AppImage issue you found I think is only related to the initial login, not related to the screenshot you posted, so I don’t think that would help.

Thank you so much for your suggestions. I’ve tried them all and the only that worked was using Firefox with all the protection disabled. I can live with that only for websites I use with Anchor. It may also be an issue with my Linux config as I don’t recall having this issue using Windows.

Hopefully, this won’t be an issue in a future release.

Thank you once again.

1 Like