EOSCommunity.org Forums

Anchor Wallet can't connect

I have a problem with my Anchor wallet.
I downloaded the new version and made an update.
All seems to be fine.
I tried to import my private keys and always got the error:
“Failed to locate an account.The account name or public key could not be found.”
I think I found the error. Anchor seems to be
“Unable to connect to the EOS blockchain.
https://eos.greymass.com is not responding to requests.”
I tried an API test run and Anchor found about 12 API’s with good response time.
But whatever API I choose. Anchor wallet ist still showing;
“Unable to connect to the EOS blockchain.”
Don’t know what else I could do…
Cheers, Jake.

If you visit https://eos.greymass.com in your web browser, does it display some code looking text, or does that page fail to load for you as well?

Hi aaron, I see code looking text.

Now I don’t see that red warning sign anymore. Maybe it’s connected. But either way I still get the message:
Failed to locate an account.
The account name or public key could not be found.

I have to say that I exported public and private key from scatter (owner account).
I wanted to be sure that my keys are o.k. and therefore I exported them.
Strangely if I connect blocks.io to scatter I see different keys over there.
Owner and active keys are the same at blocks.io.
Maybe it has something to do with my keys that I cannot import in Anchor wallet?

If there’s no red warning sign, then yeah you’re probably connected now. Not sure why it was causing you problems, pretty strange.

There’s a few reasons your account might not be found:

  1. The API you changed to might not support lookups of keys like this. Sadly it’s a feature missing on some APIs. At this point we should probably hide any API that doesn’t support it. A few I know will work is ours (https://eos.greymass.com), the one by EOS Nation (https://api.eosn.io) and EOS Sweden (https://api.eossweden.org). If you go into Manage Blockchains, and click the gear icon on the EOS blockchain, you can change it manually to any of these endpoints to connect with them. Try the import then.
  2. The other thing it might be is that it’s not the right key. Go into Tools and look for the Key Converter. That’s a tool that will let you enter a private key and it’ll show the associated public key for it. The public keys on that screen in Anchor should match what the keys section of bloks.io shows for your account. If they do not match, then its not the right key.

Hopefully one of those two things helps!

Thanks aaron,

Unfortunately both things don’t work.
I was connected to EOS Nation and EOS Sweden but got the same error message.

Than I used the key converter and got a new Standard Key Format key pair.
I thought great, but unfortunately this private key led to the same error message:
Failed to locate an account.

Does the public key shown in the Key Converter match what’s shown on your account in bloks.io?

My concern right now is that the key you have isn’t the right key. All of those APIs should be able to return the account for you, if the keys do in fact match.

I absolutely don’t know what’s going on…
I have a scatter twelve word seed and I have a scatter password.

If I log in at blocks.io with scatter it shows me my account:
This is for sure my account. It matches with my personal data.
I have staked my eos in my account.

I see an owner key in scatter and exported this owner key and the private key belonging to it.
If this private key scatter is showing to me is the wrong one how could this be ?
And this owner key (public and private) is matching with my personal data.
There is no error.
Could scatter sho me a wrong private key for my owner address?

At blocks.io if I enter the new public key or the old public key it says also
“EOS Account Not Found”

What am I missing here ?

Looking at your account - it looks like your keys were changed on September 28th. Those key changes look like they were a part of a phishing scam of some kind, claiming to be free CPU from Voice or B1. Do you remember logging into some site and signing a transaction related to that?

This transaction specifically is what tipped me off to the situation:


At the bottom it shows a “Free resources from Block.one!” and then proceeds to change the active/owner keys of your account. I wish I had better news or a solution for you but I’m afraid there’s not much I can do.

Thanks aaron for your help.

Yes, I see what you mean.

I think you are right. For the first time in crypto space I was scammed.

Normally I am very cautious. But in this case I wasn’t. My fault.

It’s happened to the best of us, myself included.

Not a problem, I’m happy to help. I just wish the circumstances were different!