EOSCommunity.org Forums

Anchor Wallet Cannot connect with Atomic Hub

Hi guys,
I’ve downloaded Anchor and set it up.
But the only issue is that I cannot connect it with Atomic Hub.

I don’t have the app integration toggles.

When I click on Launch anchor on the pop up.

There is nothing happening.

Anyone can help ?

No app integration function

Anyone can help me ?

The app integration is on by default now and moved from the sidebar, which is why it’s not shown here.

There’s a few things this could be. First though, a few questions:

  • Which operating system are you on? Linux, specifically the AppImage, has a problem with the setup that prevents it from handling those links properly.
  • Which browser are you using? Some browsers recently (Brave) broke some of the functionality required to make that link work.
  • Do you have Wombat’s browser extension installed? They recently updated and started taking over all the links Anchor uses to open those links - which can be disabled in the Wombat settings. I believe it’s called “Anchor Authentication”.

Hi Arron. Thanks for your reply.

  1. I’m on Windows 10.
  2. Using Chrome Browser.
  3. Never heard of Wombat browser.

Hope my issue can be solved :slight_smile:

Thanks a lot!

Thanks! Based on your answers, I don’t see a reason why it shouldn’t be working, unless something is actively preventing it from Triggering the request in Anchor.

Out of curiosity, if you open an Incognito/Private window in Chrome, does it work then? Another thing to try would be seeing if another browser works, and see if maybe it’s a Chrome extension or Chrome itself that’s causing the issue.

If you do want to try to turn it off and back on again, click the gear icon in the top right of Anchor. There’s an “Allow signing requests from external applications” option there, which you can change.

I tried on opera, brave browser and Edge. Same issue. It doesn’t trigger the request in Anchor :confused:
I also tried to turn on and off the “allow signing requests from external applocaion”.

Maybe it’s the antivirus ?
Or Windows Defender ? The firewall ?

Alright - so not a browser issue.

It could be the antivirus preventing the link from opening an external application. I’m not well versed on antivirus these days, but I could see that being a thing.

What version are you on? If you’re on an older version, updating would be something worth trying. You can click the “Help” menu and then “Check for updates” to automatically download the newest version.

Ok Aaron. it was my Firewall (Comodo). It prevents Anchor wallet to launch…

Many thanks :smiley:

1 Like