EOSCommunity.org Forums

Anchor lags on Mac

There is considerable delay between keyboard entry and response from Anchor on MacBook Air.
Has anyone noticed this?

It can be pretty slow right after it starts up, especially if you have a bunch of accounts loaded in that all need updating. Once it catches up though it’ll generally be more performant.

One thing you can tweak is in the settings, the “Account Update Frequency”. It’s how often the wallet asks the API for fresh data about your account.

Aaron, where is this Account update frequency? I can’t find it. I don’t see it under application settings.

What version are you using?

anchor-beta 1.0.0-rc8

As a first step I’d encourage you to upgrade. That’s quite the old version and we’ve made a number of improvements since the beta.

I’m not sure if an automatic update will work or not from the beta version to release. You can try via the “Help” menu and “Check for Updates”.

If that doesn’t work, a fresh install and setting it up again (either restoring a backup or just importing your keys) will be the way to go.

@aaron Hi Aaron, I updated the Anchor. Now I am using version 1.2.3

I can’t seem to update permissions while using ledger. I tried within Anchor as well as with Bloks using Anchor. Enabled allow dangerous transactions. I get the message saying contract data must be allowed on Ledger - but it is already enabled.
Can you try changing permissions with Ledger and let me know how to solve this?Screen Shot 2021-06-18 at 3.12.13 PM

I’ll have to do some testing. I heard a report earlier this week about key change problems while using a Ledger, so it’s likely not just you and your account.

I’ve opened an issue on Github to track this and hopefully we’ll get a release with a fix out soon.

@aaron Hi Aaron, is this issue resolved?

Sort of. If you downgrade to a previous version of the EOS Ledger app, apparently it resolves the issue. The teams behind the Ledger app are aware of the issue, and we’ll have to wait for a fix from them.

I tried this - did not work.
after changing Setting/Experimental features/ Manager provider/4 - I still can’t see EOS 1.4.1 there. I only have EOS 1.4.2 and can’t change permissions with that.

I haven’t tried these steps, so I’m just relaying what I’ve been told could work.

If it doesn’t work, the only thing I can think of is that we will need to wait for the next release, at which point hopefully they will have a fix in place for it.

@aaron Aaron, something wrong with anchor. There is a delay between signing the transaction and the execution. I sometimes have to wait couple of minutes or repeat signing the transaction again.
quite frustrating

I have noticed it taking a while to show up on block explorers or update balances recently as well. Over the weekend I thought a transaction failed between my accounts, so I did it again, and ended up doing the same thing twice.

Is that what you’re referring to?

If so - I think it’s a network related issue (either API or P2P) and not directly related to Anchor. I haven’t had a chance to look into why things are slower than usual yet, but it’s on my radar to look at if it persists.

yes, that is what I am referring to - I sometimes do the same transaction 2 or 3 times – because it is frustrating to wait for 2 or 3 minutes. Is it possible to change the API that anchor uses? Is it under settings or somewhere?

Yeah you can. The blockchain dropdown in the upper left has a “Manage Blockchains” option, which displays all the blockchains you have configured. Clicking the gear icon on any of them allows you to change which API it uses.

You can find which APIs have the best response time for you either by using the API Analysis tool found in the Tools section, or sites like the EOS Nation Validator Tool maintain a list of live APIs.

@aaron Aaron, any idea what is going on with Defibox desktop? I can’t login with Anchor — (can login with Scatter).
Nothing happens when I click on Anchor icon for login – I am using Chrome on Mac.

same thing with Firefox on Mac – nothing happens when I click on Anchor icon for login

I’ve seen a few people report this and tested myself, it seems the default API they use is failing and that’s the reason things aren’t working.

There’s a wifi looking icon in the bottom right of the page, which you can use to change API servers. Change that, and the login should work.