EOSCommunity.org Forums

Nano Ledger S (contract data enabled)

Despite having contract data enabled I keep getting this error for specific actions (managing keys and permissions).


To further complicate things, I cannot find “arbitrary data” on the nano S, once entered in the EOS app.

I’ve got the most recent firmware, and I’ve even uninstalled eos from the hardware wallet and then reinstalled. Still running into the same problems…
For the most part everything works fine, with the exception of changing keys or adding permissions…

It’s called “Contract data” now I believe in the settings of the app on the Ledger. Make sure that’s enabled.

Someone else did mention recently they were having problems with this too, it’s possible there’s a bug we haven’t tracked down or something. After hearing about it the first time, I went to do testing and was able to update the keys and add permissions using a Ledger - so it’s not a constant issue.

If enabling the contract data doesn’t do it - feel free to try using the Ledger directly with bloks.io or another web wallet that supports Ledger and see if you can change keys that way.

1 Like

Hi Aaron thanks for getting in touch.
I have a suspicion that it might be my Ledger causing the issue.

Firmware is up to date
EOS app is up to date
Keys correspond with the index keys on the ledger
and everything else can be signed and executed just not managing keys and permissions.
Using the ledger directly with bloks.io and EOSAuthority gives me the following errors.

Error on eosauthority

Error on Bloks.io

I’ve pushed this issue to Ledger Wallet’s team, and they are investigating it on their side. I don’t believe this is an Anchor Wallet issue, as EOS authority or Bloks.io are unable to execute keys/permission management transactions either.

Ledger Wallet’s team currently believe that because the hardware wallet can sign for all other txns that the hardware itself is not damaged.

My issue has been posted on reddit and can be found here:

This Issue has been resolved.
Currently the solution is to downgrade the EOS app on the nano ledger from 1.4.2 to 1.4.1

As found here

Uninstall your EOS app, and then switch Ledger Live to provider 4 (Settings/Experimental Features/Manager Provider/4)
Go back to Manager, EOS 1.4.1 should be available. Install it

1 Like

Thanks for the follow up and asking the Ledger team!

Multiple people have approached me with this same issue. For the time being, I’ll refer them to this as the solution.

1 Like

@Raccoon I tried this - did not work. I followed these steps -
Uninstall your EOS app, and then switch Ledger Live to provider 4 (Settings/Experimental Features/Manager Provider/4)
I don’t see EOS 1.4.1 - 1.4.2 is the only option to install.

Strange. I uninstalled the EOS app on the ledger itself and not on Ledger Live perhaps that might make a difference. Also try closing Ledger Live after switching to provider 4, then after restarting the app download the EOS app (no matter the version number) and then try use your Nano Ledger to sign permissions/change key transactions to see if it works.

Just tried the method described in your post and can confirm that it works.

1 Like

@mgbtcfv I just tried the method that @Raccoon posted and it worked for me.
If it’s still not working for you, this is exactly what I did:

  1. Deleted all apps from the Ledger Nano S
  2. Switched Ledger Live app to Provider 4 as described above.
  3. Restarted Ledger Live
  4. Connected the Ledger Nano S to Ledger Live
  5. Searched for EOS App in Ledger Live and installed version 1.4.1. It was the only option available
  6. Enabled Contract Data on the Ledger Nano S
  7. Closed Ledger Live.
  8. Connected the Nano S to Anchor and proceeded to update permissions on my account without any problems.

I was using Ledger Live version 2.32.2 on Ubuntu.

Hope that helps.

1 Like

I’ve had the same issue and tried the steps, like @mitsugirisan described. It works great!!!
Thank you so much!!!

1 Like

Can you then reinstall all the apps that were deleted or do you have to change the Provider back to the original state?


You can reinstall the apps again.

EOS doesn’t show up as an available app after going to “Provider 4” in the settings.

Only thing I see when searching “EOS” is “REOSC(REOSC) version 1.9.12-xdc” which is not EOS.

Does this fix still work?

Weird, I think it still works. I just did a fresh install of Ledger Live on a new machine, went into Experimental Settings, enabled the manage provider section and changed it to 4, and do still see the old app:

1.3.1 as far as I know is the version that still works.

Not saying it’s not happening for you, but I think it might still be possible.

I also don’t see Eos app on Nano X manager provider 4 i only see REOSC

ahh, yes im using Nano X as well. Maybe that is the issue

I’m using Nano S and when changing the manager provider to 4, no EOS app is showing up, there’s only four apps.

Any clues on what might be happening?

BTW shouldn’t this have been fixed already on a newer version, it’s been 6 months since the problem was found? Does anyone know if this app is still supported?

I wish it was - the individual who built that app isn’t actively maintaining it, and the Ledger team hasn’t resolved the bug yet either.

We have some working groups doing research on some of the major outstanding issues in EOSIO to find individuals/teams to resolve them, and this is one of the issues on the list.

I’m also not sure why it’s disappeared. It still shows in my list with I use manager provider 4… :thinking:

Not sure what to tell you - the Ledger team that manages that directory of apps would probably be the only ones who know if there was some change that removed it in some situations. I’d ask them but I don’t have a line of communication open with them at this point.