EOSCommunity.org Forums

Nano Ledger S (contract data enabled)

Despite having contract data enabled I keep getting this error for specific actions (managing keys and permissions).

Help.

To further complicate things, I cannot find “arbitrary data” on the nano S, once entered in the EOS app.

I’ve got the most recent firmware, and I’ve even uninstalled eos from the hardware wallet and then reinstalled. Still running into the same problems…
For the most part everything works fine, with the exception of changing keys or adding permissions…

It’s called “Contract data” now I believe in the settings of the app on the Ledger. Make sure that’s enabled.

Someone else did mention recently they were having problems with this too, it’s possible there’s a bug we haven’t tracked down or something. After hearing about it the first time, I went to do testing and was able to update the keys and add permissions using a Ledger - so it’s not a constant issue.

If enabling the contract data doesn’t do it - feel free to try using the Ledger directly with bloks.io or another web wallet that supports Ledger and see if you can change keys that way.

1 Like

Hi Aaron thanks for getting in touch.
I have a suspicion that it might be my Ledger causing the issue.

Firmware is up to date
EOS app is up to date
Keys correspond with the index keys on the ledger
and everything else can be signed and executed just not managing keys and permissions.
Strange.
Using the ledger directly with bloks.io and EOSAuthority gives me the following errors.

EOS AUTHORITY:
Error on eosauthority

BLOKS.IO:
Error on Bloks.io

I’ve pushed this issue to Ledger Wallet’s team, and they are investigating it on their side. I don’t believe this is an Anchor Wallet issue, as EOS authority or Bloks.io are unable to execute keys/permission management transactions either.

Ledger Wallet’s team currently believe that because the hardware wallet can sign for all other txns that the hardware itself is not damaged.

My issue has been posted on reddit and can be found here:

This Issue has been resolved.
Currently the solution is to downgrade the EOS app on the nano ledger from 1.4.2 to 1.4.1

As found here

STEPS:
Uninstall your EOS app, and then switch Ledger Live to provider 4 (Settings/Experimental Features/Manager Provider/4)
Go back to Manager, EOS 1.4.1 should be available. Install it

1 Like

Thanks for the follow up and asking the Ledger team!

Multiple people have approached me with this same issue. For the time being, I’ll refer them to this as the solution.

1 Like

@Raccoon I tried this - did not work. I followed these steps -
Uninstall your EOS app, and then switch Ledger Live to provider 4 (Settings/Experimental Features/Manager Provider/4)
I don’t see EOS 1.4.1 - 1.4.2 is the only option to install.

Strange. I uninstalled the EOS app on the ledger itself and not on Ledger Live perhaps that might make a difference. Also try closing Ledger Live after switching to provider 4, then after restarting the app download the EOS app (no matter the version number) and then try use your Nano Ledger to sign permissions/change key transactions to see if it works.