EOSCommunity.org Forums

JavaScript error ocurred in the main process

Без імені

Windows 10
Anchor 1.2.9 also test 1.3.0 same error
An error occurs when starting the anchor

1 Like

Hrm, from the bit of research I did this afternoon it looks like some sort of antivirus or protection software is preventing part of the app from running - resulting in this error.

Do you have any security software like that installed, and if so, have you checked them to see if there’s any messages about it blocking Anchor when you try to run it?

Malwarebytes was installed, but he did not complain and there were no reports from him
Now I deleted it and tried to run Anchor but the error remained
Also already reinstalled Anchor, but it didn’t help

Try right-clicking on Anchor (or the installer) and choosing to “Run as Administrator” to see if that clears up the problem. Maybe its that the user you are logged in with currently doesn’t have sufficient permissions to run the app?

Checked “Run as administrator” - no effect
Running the “Run as administrator” installer to reinstall - no effect
Provided full permission for all users and groups in the properties of the program - no effect

Maybe you need a log file to determine what the problem is?
Now it looks like the only option is to reinstall the operating system, but I would not like to do so

There is a log file, but I’m pretty certain it’s going to say the same thing the screenshot you posted does.

Anchor isn’t starting at all from the looks of it, which is preventing any of our specific code from being able to log anything more detailed about what’s going on. The operating system itself is preventing Anchor from even starting and I’m not entirely sure why yet.

Out of curiosity, have you tried restarting the machine?

One last question - in each of the tests you’ve done, are you getting the similar “Access Denied” error message like in the original screenshot?

So of course, I restarted the computer

Yes, the error is the same

Solved the problem:

  1. Created a new user
  2. Granted him the privileges of an administrator
  3. I took away these privileges from the current user
    And everything was decided
    For some reason, this administrator lacked administrative rights


How weird is that… but good to know! Thanks for following up, that’ll be useful knowledge to have in the event someone else runs into this situation.