EOSCommunity.org Forums

Issue with connecting to WAX Blockchain


Recently installed latest version of Anchor on desktop (1.2.3) and create a wax wallet. But when I’m trying to login on atomichub using anchor nothing happens even if the popup to confirm transaction appears. While looking here to find a solution I found out that I don’t have the box “EOSIO Signing Request”. Went to the settings of WAX Blockchain and it says that it couldn’t connect to https://wax.greymass.com, even by clicking on “retry connection” nothing happens. If anyone would know a solution to that thank you!


Hrm, I just tested things out and it appears everything is working fine.

Any chance you’re doing other things on WAX, like mining alien worlds or something? I’m wondering if you are caught in our spam filters and its preventing you from connecting.

It’s a fresh account I created 2 days ago. Haven’t done anything with it yet.

It’s not so much about what’s being done with your account, it’s more about what you’re doing on WAX in any app while using our APIs. Our APIs start to filter people out based on their IP address if they’re using some of these other WAX apps that get rather spammy.

Understood, so yeah been playing Alien Worlds for 2 weeks and stopped a week ago.

Well I don’t think you’d be blocked just for playing. I’m just looking for reasons why you might not be able to connect, and the most likely one just being that some app you were using was sending a lot of requests and our APIs just cut you off to protect the service for everyone else.

There’s a lot of poorly written apps out there. I personally don’t know which they are and am not pointing fingers, I just know there’s a lot of things that make very rapid requests to our servers and make it slow for everyone else.

Anyways - still not sure that’s what’s happening here, I was more just asking.

Can you visit wax.greymass.com in your browser? It doesn’t load a webpage, but it should load some text.

I’ve been using the following app: Alien Wrolds, Koloboks, Rplanet, I think that’s all, I don’t remember using other app.

This is the text loaded by the page:


Alright, so the page loads correctly. That’s what you should expect from them api.

Anchor still isn’t working? Do you have a vpn in your browser that’s letting it connect while your computer can’t?

Its odd the browser is fine but Anchor is not.

Anchor still doesn’t work indeed. I don’t use any VPN. Tried to uninstall Anchor and reinstall it but still can’t connect myself to the api. Haven’t change any setting too.

Any special kind of security software installed that might be preventing the app from reaching out to the internet?

One thing you could try is using a different API and see if maybe that works. In the “Manage Blockchains” area of the app, there’s a gear icon on each network that lets you edit the settings. You can edit the settings for WAX and try using one of the following:


If those don’t work either, then there’s definitely something on your computer that’s preventing Anchor from connecting to the internet.

Ugh, sorry about the headaches here, this issues are no fun to try and figure out :sweat_smile:

Yeah already tried yesterday different api had the same issue. It’s really weird because I don’t think I have ever installed something that would block the connection.

Yeah sorry about that I know it isn’t fun at all. I’ll try to check my applications one by one but yeah I kinda doubt having an app that would block anchor.

Has Anchor ever worked or was this the first time you’ve installed?

First time installed, tried versions 1.2.0, 1.2.1, 1.2.2 and none worked too. But on those one I had the EOSIO Signing Request enabled and appearing. But when I click to login with Anchor on atomichub it still does nothing.

I’ve primarily been trying to figure out why Anchor itself can’t connect, which is what you shared a screenshot of. If Anchor can’t connect to the internet, then none of the dapps are going to work either.

You’re essentially reporting two issues here and I’ve just focused on the first.

However, for the second of requests not appearing - which browser, and any adblocking extensions? I’ve seen reports that some browser and/or adblockers seem to block Anchor links by default, and you need to disable those protections on these sites.

In brave for example, some people have issues when trying to use Anchor on some sites with the “Shields Up”.

I’m using Google Chrome and don’t have adblocker.

Edit: Tried on firefox and worked. I’m going to reset my google chrome to factory and see if it works.

Edit2: Cleaning my google chrome worked fine too. Thanks for bringing up the browser idea, should I think about that before my bad.

1 Like

Glad to hear that worked! Wonder what it was about Chrome that was blocking it.

Either way, I’ll have to keep that solution in mind if other users experience this same weird issue.

Hi, replying to this because this seems to be what I may have tripped - my friend made a script for me and some friends for “metalwargame”, which involves around 20 transactions (one for each in-game unit) each hour for the game - to make matters worse, I don’t think I was running it correctly, so I’m probably guilty of causing an issue somewhere. Seems now I can’t connect anchor with my ip, it works fine with a vpn (as does the wax.greymass.com site) - any chance I could get it taken off the spam filters? Definitely a takeaway here for running scripts without coding knowledge :sweat_smile:

Hah - it happens. I did the same sort of things early on while I was learning about blockchains :wink:

The system will automatically lift the bans, they’re not permanent. Its been 2 hours since your post and I’d be surprised if you’re still blocked. If you are, I’d need to know the IP address you’re banned on to look for in the database - which you’re free to send over (aaron@greymass.com).

Hi @aaron,

I have the same issue like Mwoo, I’ve sent you an email with all the details, I hope you can help me I really love anchor and use it a lot every day.

Thank you so much in advance! :slight_smile:

1 Like