EOSCommunity.org Forums

Greymass Anchor wallet not working / unlocking anymore for INSTAR

So I have a Greymass Anchor wallet I was using to stake INSTAR tokens. I unlock it once a month to restake. When I checked yesterday, I didn’t see my balance and the wallet didn’t seem to be able to “connect”. I updated from 1.0.5 to the new Anchor 1.1.2 wallet, and even reset the application by importing from a backup JSON file, and also tried the private key. The private key input said - no accounts associated with key. However, I can check my account public key on the INSTAR EOSX explorer, and my balance was there. I was receiving DAILY staking rewards but there are no more after March 8th. How can I get my Anchor wallet working again? I hadn’t made any transactions, or changes to my computer or the wallet prior to this.

1 Like

I think this is actually because our INSTAR API is down right now.

If you go into the blockchains dropdown, click “Manage Blockchains”, and then hit the little gear next to it, you’ll be able to change the API node. Give this one a shot:

Edit: I just brought down our API completely so the error messages inside Anchor will trigger properly and let you know you should change APIs.

1 Like

Yes this worked, thank you!

1 Like

I’m having the same problem, I changed the API node to http://instar-api.eos.barcelona like you recommended. I then enter my private key and get the following error:

Failed to locate an account

The account name or public key could not be found.

I thought maybe I didn’t write the correct private key, but I tested it with the https://keypair-generator.instars.com/

Public Key

Private Key

Ah, it’s very possible they don’t have account lookups enabled, which are required to import an account. The above instructions should work for performing transactions but not for the initial setup.

Our APIs look to be back online as of pretty recently. Sorry to make you jump through a few hoops, but if you swap back to our API node the lookups should work once again:


FYI it says teamgreymass is unregistered. There is no option to vote for you guys at the moment

Yeah, we have decided to phase out our BP operations there. We still are offering support through Anchor and our APIs, but we haven’t been able to justify the time needed to maintain a proper BP operation.