EOSCommunity.org Forums

Eosauthority add account not working for me

Hello folks!

I am trying to add an account on the Official EOS REX interface of EOS Authority | EOS Authority page. When I select Anchor Wallet and follow the instructions, I click the button below the QR Code that would open the app, the browser shows a pop up asking me to open the app, but it does not do anything after I allow the browser to open the app by clicking the confirmation button in the browser pop up.

I am using the app image 1.2.1 (latest) version of anchor wallet. Do I need to do some kind of setup so that the browser “recognizes” the anchor wallet? (or to fix whatever is happening here).

I am using linux mint and I also tried with an ubuntu system and I got the same behavior. I am using the chrome browser.


The AppImage has had a bug in it for a while now which we still haven’t managed to track down. The desktop shortcut it creates is missing one crucial piece of information to get the application to listen for incoming requests.

You can either use the deb installer which will generate it correctly, or you can edit the desktop shortcut to add the missing characters as described in this github issue:

Hey guys!

I have the same issue. I am on a Manjaro Linux and the AppImage just looks like a standalone file and I don’t know where to even start to look for a .desktop file.

What are the alternatives to using eosauthority on linux?

Thank you all! Keep up the good work!

The deb installer is an alternative that I’m pretty confident works, as opposed to using the AppImage version. I’m not sure if what sort of support Manjaro offers for deb installers - but I feel like most linux systems have some sort of capabilities to use them.

Thank you Aaron,

I was considering that option. I was trying to save myself the work of installing a .dev on Manjaro. Lol, I apologize about the laziness.

Anyway, what I intended to do is stack my EOS at REX in order to earn passive income. But I just found out that the APR is below 1%. So, I think I will look for other staking alternatives.

@aaron @immortal I forgot to follow up in this thread and I apologize for that. I did confirm that using the deb installer worked for me.

1 Like

I did manage to make both the AppImage and the deb installer connect to eosauthority wallet on Manjaro linux. I want to stake my EOS into REX in order to generate some passive income. I haven’t been able to do the staking process though; EosAuthority keeps reporting errors.

In order to install the .deb on manjaro I used Debtap, which is a program that converts a .deb package into a .tar.xz package suitable for Arch distributions. I found Debtab in the AUR repositories.

After having the .tar.xz file, I installed using pacman:

sudo pacman -U *name-package-created-by-debtab*.tar.xz

Also, eosauthority won’t connect with Anchor wallet if your browser has some privacy extensions enabled. In my case, I have several of these on firefox so, I had to open eosauthority on Opera, which is another clean browser I frequently use.

Finally, I suspect the privacy addons on firefox have to do with the reason why AppImage didn’t work from the beginning. It seems the AppImage wallet connects fine with EosAuthority while using opera instead of firefox too.

Hope this helps.

1 Like