EOSCommunity.org Forums

Cant unstake my tokens whatever I seem to do

Good afternoon everyone,

I cannot seem te get my EOS tokens unstaked on eosauthority using the Anchor app.
If i try to unstake them I get the message: missing authority of haydemrwgqge (my account)
Whatever I do , I cant seem to change the authority… I already linked the Anchor account to this account.

I Also tried simpleos, there I get this message: Error: billed CPU time (500 us) is greater than the maximum billable CPU time for the transaction (2 us).

Ive been trying for a few days now and it’s really starting to annoy me.

Is there anyone who could help me? I would really like my coins unstaked!

Thanks in advance!

1 Like

Me too.

If i try to unstake directly from EOS Voter Desktop App - it keeps saying “error_billed CPU time (385 us) is greater than the maximum billable CPU time for the transaction (140 us)”

I had enough RAM and CPU so it seems to be a bug

Tried bloks.io - cannot connect to my Eos Voter Desktop App
Tried EOS Authority - it doesnt connect to my EOS Voter Desktop App
Tried to recover my EOS wallet through other apps (e.g. Anchor), but I;ve lost my Private Keys
Tried to recover my private keys from EOS Authority but the recovery period has expired.

Might have lost all my EOS permanently :frowning: - all because of the Bug on the EOS Voter Desktop App

How did you setup your account inside Anchor? It sounds like whichever method you used to setup the account didn’t work properly.

If you have your private keys external of the wallet (or you can export them from Manage Wallets), I’d recommend removing the account (again from the Manage Wallets section) and then add it again. Make sure you use the “Import via Private Key” method and that it detects your account, then select to import it.

This should resolve the problem.

While the eos-voter app is still functional, it’s no longer being developed and has been replaced by Anchor.

The error you are getting is because you don’t have enough resources to perform the transaction (resources on EOS are a substitute for fees). Anchor handles all of this for you, where as eos-voter relies on the legacy systems that you need to manage yourself.

You should be able to export your private keys from eos-voter and then import them into Anchor. Depending on what version of eos-voter you have, you may need to upgrade to enable that option. eos-voter version 0.7.12 was the last version, which has the export feature under the Manage Accounts/Wallets section, and in the right column of each account there’s a “View Details” option that allows you to see the key being used for the account in the wallet and export it.

If you need to upgrade, here is the download page for eos-voter 0.7.12:

You can just install the app again with the appropriate installer and it’ll perform the upgrade.

Once you have that private key, you can import it into any compatible wallet, of which I’d recommend Anchor since it’ll deal with all the resources headaches for you and allow you to connect with sites like bloks.

You can find the latest version of Anchor here:

Hi Aaron - thank you so much for the tips. I’ve just upgraded my EOS voter to 0.7.12, but

  1. Unable to upgrade my account , even with a correct password
  2. Unable to access the “View Wallet” Function under “Managed Wallets” - there’s no response from the voter after clicking the button or entering a correct password

Have you encountered this before? thanks so much for your help

Hrm, I have not. It’s also been a while since I’ve used that old version.

The one thing I am noticing though is that the “permission” is missing on the list. Note how the account above it has an @active after it, which all accounts should have :thinking:

If you click the “Save Backup” button in the upper right, that should create a file on your computer that backs up everything. You can use that file to setup Anchor, which I’m hoping will work.

Thank you Aaron,

It worked! I think I did something wrong in the account making process on anchor.
Now it takes 3 days to unstake them right?
Thanks again man, you made my week!

Yep, wait 3 days (4 at most, the timer is weird) and you’ll be able to refund and receive those tokens.

After that time is passed most likely you’ll need to manually refund the tokens to gain access to them, a process which is outlined here:

https://forums.eoscommunity.org/t/unstaked-eos-stuck-in-refunding/273/2

Hi Aaron, im having a similar issue.
Im trying to unstake some EOS tokens, I have the anchor wallet connected now but im unable to complete any transactions

I get these kind of error messages when I try to complete any transactions, my private keys are kept on my ledger

That error typically means Anchor is having a hard time communicating with the Ledger device.

There is an icon in the upper right menu bar, next to the gear icon, which shows the status of the connection to the Ledger. Click that for a menu that displays what the state of it is.

Make sure the Ledger is connected, EOS app is open, and Anchor states its connected. Sometimes other apps can prevent Anchor from talking to the Ledger, so make sure other apps that might be using the Ledger are closed. If all else fails, try rebooting, and then starting Anchor up to get it to connect.