EOSCommunity.org Forums

Calling eosio.token in Anchor 1.2.6 produces authority error

I tried to create a custom token using eosio.token create in Anchor 1.2.6 on Windows desktop and got an error reading: ‘missing authority of eosio.token’. Tried connecting Anchor to Bloks.io to interact with eosio.token through Bloks and got the same error. What’s this error about and how do I fix it?

It sounds like an issue with the contract - which I personally am not the best person to help troubleshoot.

I moved this post in to the EOSIO Development forum in hopes you’ll be able to get some answers!

1 Like

Awesome. Thanks Aaron!

Only the eosio.token account may create an eosio.token token. We never got around to implementing the automated market in eosio.token which would allow normal users to create tokens without creating new contract accounts.

1 Like

To create your own token:

  • Create a new account to host the token
  • Install the eosio.token contract on it. You’ll probably have to use cleos.
  • When logged into Anchor as that account, use the appropriate actions to create, issue, and transfer your token. Or use cleos.
  • Decide how to set up the contract’s account’s keys to enable future bug fixes and upgrades. Get this part wrong and no one will value the token.

I see. So the eosio.token account is a special account type which can’t be created with Anchor, Bloks, etc.? And without this special account the eosio.token contract can’t work even though this contract itself is accessible on Anchor, Bloks, etc.? Thanks for the reply!

It’s not a special account type. Let me put it this way:

  • The contract may be installed on any account x
  • Account x must authorize the create action. i.e. Anchor must be logged in as account x if you’re using a web UI.