EOSCommunity.org Forums

Anchor Wallet not recognising Scatter keys

Hi everyone,

I know I am not the first person to have this issue but I have checked previous posts and haven’t had any luck trying options that others have tried.

I have got an amount of EFX tokens in my Scatter wallet, I can see them but I can’t send them. And I also can’t get Anchor to recognise my Private Keys from Scatter.

In fact, I have only managed to get Scatter to show my keys once, everytime I ask to show me the keys, it just gives me a box with a spinning red circle where the QR code should be, and the text option doesn’t populate. I have tried so many times but it just won’t work.

The keys I have managed to generate, when I input them into Anchor (Desktop App) it says this *“Failed to locate an account. The account name or public key could not be found”

I have also been on bloks.io and I can see my balances, but when I try and send anything, it won’t send. I’m not even sure if I can actually send from Bloks.io site anyway?!?

Any help with this would be hugely appreciated, it’s not life changing amounts of tokens but it’s worthwhile trying to get them released into a wallet I can actually use.

Thanks… Matt

While I can’t help with Scatter (been ages since I’ve looked at it), there’s a couple things it could be which I’ll try to outline here.

I guess first off, if you can’t export them from Scatter, did you have a backup of your keys anywhere else? Having those original keys is pretty key in how you’d move from one wallet to another.

When you say generate, are you making new keys? I ask because you can generate an unlimited number of keys, but unless they are actually associated to the account you want access to, they are just blank keys that aren’t actually in control of the account. The right keys are needed, since they basically act like passwords to access the account.

One thing you can do is take the keys you have, whether from a backup or from Scatter (if it exports), and go into the Tools section of Anchor (left sidebar) and into the key validator. There you can paste a private key, and it’ll return the associated public key. This public key should match the “Keys” section of the account when you view it on a site like bloks.io.

By any chance did you change the server that Anchor uses in the settings? If so, it’s possible the server Anchor is connecting to doesn’t have the required features to do key lookups. The default server Anchor uses (eos.greymass.com) should have this feature though.

Hi, thanks for the reply, hopefully we can work and find a solution… :slight_smile:

I am running Anchor desktop version 1.3.1 but there is no sidebar with ‘tools’ can you send me a screenshot of what it should look like please?

I have checked my server and it appears to be the correct one?


Also, the address showing on bloks.io matches the address in my Scatter wallet…

Hi Aaron, is there any chance you can help with my access issues? I still can’t access my account. I don’t have the sidebar with the tools on that you describe?

Thanks… Matt

Sorry for the late response!

If you go into Settings (gear in the top right), you can enable “Advanced User Options” and the sidebar menu should appear.

Hi Aaron, Merry Christmas Eve… alas I am still struggling with my Scatter account.

I have learned that the keys I have been creating are not the ones I need, and they won’t link to the primary account to help me anyway.
Back to the beginning…
I can login to my Scatter wallet, and I can see my balances, when I try to get my Private Keys, it simply won’t generate them for me, I just get this spinning red box (See pic attached if it works)
I have been on Bloks.io and again I can see my wallet and balance but can’t do anything with the wallet.
I have actually found a json file associated with the Scatter wallet (Seems to have been created the same time as my wallet) Is this in any way useful to help me send my funds out of this hellish wallet and into Anchor??

Fingers crossed…


ps… I now have the tools setup as you suggested
Scatter KEY failed

What happened in the end please?
I’m trying to get my chintai off scatter and onto anchor but when I enter the private key it says it’s connected but the balance is zero (I can see the balance on scatter).
If I try and transfer it anchor says I need to enter a memo and an address but on scatter there is only 1 field and when I try it it for a nominal amount it says the recipient you entered is not a valid recipient for Chex
Very frustrating