EOSCommunity.org Forums

Anchor Wallet not detecting newly created WAX account

Hey there! I was trying to create a new WAX wallet using a custom username and using the keys generated by Anchor. Things seem to go smoothly until the part where I try to find the available account via “Automatically Detect”. Tried several times but it doesn’t link me to the account that I created. I can see the account visible on the blockchain here: https://wax.bloks.io/account/distanciawax

Manually using the “Import Private Key” to find the connected account doesn’t work either.

Any ideas on what might have gone wrong?

I have the same problem it doesn’t detect the account

@distancia @shakan
Have you enabled the WAX blockchain inside anchor wallet?

There’s a more detailed guide about Anchor Wallet here: https://forums.eoscommunity.org/t/getting-started-with-anchor-wallet/61

The key indexer right now is unfortunately falling behind the blockchain and we’re working to resolve the issue. The account should show up eventually - it’s just not immediate until we get the fix in place.

I’m assuming if you try now, it finds it?

The import button doesn’t work for me

yes but impossible to import and detect the account I have the 1.2.1 version

It’s because it’s not detecting any accounts. The accounts would be displayed below the input box and allow you to select which accounts to import.

The key indexer is roughly 4.5hours behind current, so if you just created a new account, it’s delayed in processing through our key lookup service.

We’re working on it.

1 Like

Hey there Aaron! Yup the account shows up now, was suspecting that it was delayed or something but i thought since it’s been 2 hours ish it would show up. Thanks for your help!

This should be resolved now on our end. New accounts should only take at most a minute or two before they can be found by Anchor :+1:

1 Like

it is still not resolved I created my account an hour ago and it still doesn’t show up in the desktop wallet import section.

Here is my account on blockchain https://wax.bloks.io/account/noha.gm . And it is very difficult to find this forum to ask for support, there is no link to it on your website. I somehow managed to find your telegram group and there you had mentioned about this forum in one of the pinned messages. Please add a link on your webpage for support.

Looks like the battle with the delay issue on the APIs continues :frowning:

I just pushed another update that’ll bypass the old APIs it was using to use some new APIs. Try restarting Anchor (make sure it’s not running in the system tray) and give it another try. The restart will cause Anchor to recognize the new APIs that are available, and then it should use them instead of the broken ones.

We’ll get that updated :+1:

Yes I can see my account now.

1 Like

Still experiencing the same issue.
Tried to add two new accounts and the walled does not find them after adding the private key




Hello I dowloaded Anchor wallet for ios and payed 2.49 to create WAX account, after i tryed connecting to neftyblocks and got a messege ( action’s authorizing actor ‘sota.gm’ does not exist) on other sites, also writes that the account does not exist, and it is also impossible to connect to the PC version of the application, since it is reported that this private key does not exist, although I copied it from the application and it starts at 5
Can you help me pls (21 hours have passed since then)

It doesn’t look like the account was actually created. Did the purchase actually go through?

Send us an email to support@greymass.com and we can get this sorted out for you.

1 Like

I contacted support there, they gave me a link to create a new account and told me to delete the faulty old one, after creating it, when I enter the site, I write that I do not have enough RAM, is this the way it should be? if so, what is the point of buying an anchor wallet if, with the same success, I can create a regular one? after all, both there and there you will have to buy RAM

RAM is a network resource used to store things on the network, and has to be purchased from the network itself. The accounts Anchor creates don’t offer additional RAM (due to potential attack vectors), but you can purchase more directly from the network just like you can with any other wallet.

I think the WAX Cloud Wallet offers some free RAM - but even if you use that all you’d have to purchase it from the network.

You can log into various interfaces using your wallet to make that purchase from the network: