EOSCommunity.org Forums

Anchor not responding when attempting to unstake

Hi
Years ago I was encouraged to buy EOS. I did this, it’s not much but I want unstake it and move it a exchange. I followed the instructions to do this via the Anchor wallet but would get an error when signing. Eos authority would ask me to open Anchor and sign. This worked but the authorisation error would occur. I think I figured I hadn’t set up the Anchor wallet properly with the correct private key. Fixed this and could see my account name (owner and active) but now the wallet doesn’t respond when attempting to sign. Any help would be appreciated.

Addit: eos authority does ask me to open on my iPhone 12 max pro but app doesn’t respond. I’m assuming I need to go back to where I scan a qr code from the eos authority.

This could potentially be an issue with EOSAuthority - have you tried using either bloks.io or another web wallet in conjunction with Anchor?

No, I haven’t tried anywhere else. I thought I had to use eos authority. I’ll have a go. Cheers.

Thank you. It now shows the staked amount as ‘refunding’. I don’t know what that means.

Wait a sec…on authority it’s on timer. So I’m guessing I just need to wait.

Unstaking takes 3-4 days to complete, at which point you’ll need to perform a “Refund” action to claim the tokens as a liquid balance :+1:

Hi aaron, I think the unstaking transaction should be completed with a message saying what you just said. I have many feedbacks of people panicking because there funds are stuck on “refunding”. I know it’s not greymass’ job but wanted to have your opinion on that. And if you approve do you know who to ask this to ?
Also, why do you keep the “Add” and “Reduce” options for CPU and NET on Anchor if it is now useless ? Also had feedback that it confused some people.

Thanks !

Yeah - it sadly is a side effect of how EOS works right now. It should automatically refund the tokens and you shouldn’t have to claim manually… but it seems like the vast majority of the time its required right now.

On top of that, like you mentioned, since staking is pretty much phased out it hasn’t brought much attention to the issue for accounts who are currently staked.

It’s honestly just a lack of time. It absolutely should be removed for networks like EOS where staking is effectively useless. The in-app interfaces in Anchor have sort of taken a back seat to a lot of the other more foundational pieces of software we’re working on - and at some point in the future we will likely be directing people to use web-based interfaces (like wallet.greymass.com) paired with Anchor to do these sorts of operations. We can build these web interfaces a lot faster than we can issue updates to Anchor :sweat_smile:

Do you know why it’s like that the vast majority of the time rn ? I’m not very good in the technicals but it’s about updating the EOS code, to :
- write a message like I proposed
- make sure that people don’t have to manually claim
- some other minor stuff that make user experience frustrating
If it’s that I guess devs would have to identify the changes to make and the BPs should reach consensus to update the code right ? Is that too difficult in practice ?

Thanks for the Anchor response :slight_smile: Glad to know you are well aware of that. User experience is so crucial, I love Anchor but wouldn’t recommend it to a complete newbie that wants to start using EOS by fear of scaring him. I usually recommend Wombat at first, with which getting in is very easy and simple. And I recommend to move to Anchor if they want to use EOS more deeply. But that’s fine, I guess both wallets complete each other even though I think there are still progresses to be made to make the user experience the best possible :slight_smile:
Fyi we are writing tutorials on Anchor in french for the french speaking EOS community and will make sure to cover the most features possible in an easy to read and easy videos to watch way. We are of course using the infos on this forum to feed our tutorials.